strange error during mail synch - when a certificate is used to authenticate, sometimes certificate cannot be validate

bongio's picture

bongio

Joined: Dec 3, 2013
No votes yet

We have the following situation:
- native ios email client
- certificate for user authentication.
- ios 7.04 (this happen even with 6.x.x)

Usually it works fine, but sometimes for some users we have a strange behaviour:
- the error is "..certificate cannot authenticate.." or mail client requests a user password
- after a lot of log checking, it appears the device does not arrive to external firewall, then the exchange too

We checked the error is showed immidiatly and it appears the device does not try to connect to the external url

Debugging the ipad we see this type of error:
Nov 28 15:42:18 s-iPad MobileMail[174] : 0x17da9130|EAS|Error|Failed to get version string
Nov 28 15:42:18 s-iPad MobileMail[174] : 0x17da9130|EAS|Error|error syncing folder: Error Domain=MFMessageErrorDomain Code=1054 "The operation couldn’t be completed. (MFMessageErrorDomain error 1054.)"
Nov 28 15:42:18 s-iPad MobileMail[174] : 0x17da9130|EAS|Error|ASGetOptionsTask failed: Error Domain=DAErrorDomain Code=63 "The operation couldn’t be completed. (DAErrorDomain error 63.)"
Nov 28 15:42:18 s-iPad MobileMail[174] : 0x17da9130|EAS|Error|Failed to get version string
Nov 28 15:42:18 s-iPad MobileMail[174] : 0x17da9130|EAS|Error|error syncing folder: Error Domain=MFMessageErrorDomain Code=1054 "The operation couldn’t be completed. (MFMessageErrorDomain error 1054.)"
Nov 28 15:42:18 s-iPad MobileMail[174] : ERROR: MFMessageErrorDomain/Missing Password - No password provided for “Exchange ActiveSync”

If I enter in settings\mail,contact,calendar\email_configured and I turn off and turn on the "Mail", the mail client starts again to work. After some hours, it stop again...
It appears a device problem, but now we have 400 devices, the end use cannot access the email configuration and this error is becoming a big issue.

Thank you for your help

Top
jvuk_BSI's picture

jvuk_BSI

Joined: Dec 5, 2013

We have the same problem - strange error during mail synch whe

Your rating: None

We have the same problem as bongio Puzzled
It seems that the problem occurs only on the iPhone (4S, 5) after updatitng to iOS 7.0.x.
On iPad (also iOS 7.0.x) and the same user, same certificate and same Exchange account works without errors.

Any clues?

Thank you for your help,

Jože

Top

Who is online?

There are currently 0 admins, 1 user and 47 guests online. Connected users: SheriffDane.